Cours Théorèmes de Bezout, Gauss
Exercice d'application

Exercice : Arithmétique, équations - Annale BAC 2016

Pour tout couple d’entiers relatifs non nuls $(a,b)$, on note $pgcd(a,b)$ le plus grand diviseur commun de $a$ et $b$. Le plan est muni d'un repère $(O; \vec{i}, \vec{j})$.

 

1) Exemple. Soit $\Delta _1$ la droite d'équation $y = \dfrac{5}{4} x - \dfrac{2}{3}$.

A) Montrer que si $(x, y)$ est un couple d'entiers relatifs alors l'entier $15x - 12y$ est divisible par $3$.

B) Existe-il au moins un point de la droite $\Delta _1$ dont les coordonnées sont deux entiers relatifs ? Justifier.

 

Généralisation

On considère désormais une droite $\Delta$ d’équation $(E) : y = \dfrac{m}{n} x - \dfrac{p}{q}$ où $m, n, p$ et $q$ sont des entiers relatifs non nuls tels que $pgcd(m,n) = pgcd(p,q) = 1$.

Ainsi, les coefficients de l’équation $(E)$ sont des fractions irréductibles et on dit que $\Delta$ est une droite rationnelle.

Le but de l'exercice est de déterminer une condition nécessaire et suffisante sur $m, n, p$ et $q$ pour qu’une droite rationnelle $\Delta$ comporte au moins un point dont les coordonnées sont deux entiers relatifs.

 

2) On suppose ici que la droite $\Delta$ comporte un point de coordonnées $(x_0 , y_0)$ où $x_0$ et $y_0$ sont des entiers relatifs.

A) En remarquant que le nombre $n \ y_0 - m \ x_0$ est un entier relatif, démontrer que $q$ divise le produit $np$.

B) En déduire que $q$ divise $n$.

 

3) Réciproquement, on suppose que $q$ divise $n$, et on souhaite trouver un couple $(x_0 , y_0)$ d’entiers relatifs tels que

$y_0 = \dfrac{m}{n} x_0 - \dfrac{p}{q}$

A) On pose $n = qr$, où $r$ est un entier relatif non nul. Démontrer qu’on peut trouver deux entiers relatifs $u$ et $v$ tels que $qru - mv =1$.

B) En déduire qu’il existe un couple $(x_0 , y_0)$ d’entiers relatifs tels que 

$y_0 = \dfrac{m}{n} x_0 - \dfrac{p}{q}$.

 

4) Soit $\Delta$ la droite d’équation $y=\dfrac{3}{8} x - \dfrac{7}{4}$.

Cette droite possède-t-elle un point dont les coordonnées sont des entiers relatifs ? Justifier.

 

5) On donne l'algorithme suivant :

Variables :

$M, N, P, Q$ : entiers relatifs non nuls, tels que $pgcd(M, N) = pgcd(P, Q) = 1$
$X$ : entier naturel

Entrées :

Saisir les valeurs de $M, N,P,Q$

Traitement et sorties : |

Si $Q$ divise $N$ alors

 

$\quad \quad$ $X$ prend la valeur $0$

 

$\quad \quad$ Tant que $\left( \dfrac{M}{N} X + \dfrac{P}{Q} \text{ n'est pas entier} \right) \text{ et } \left(-\dfrac{M}{N} X + \dfrac{P}{Q} \text{ n'est pas entier} \right)$ faire

   |

$\quad \quad \quad \quad$ $X$ prend la valeur $X+1$

 

$\quad \quad$ Fin tant que

 

$\quad \quad$ Si $\dfrac{M}{N} X + \dfrac{P}{Q}$ est entier alors

  |

$\quad \quad \quad \quad$ Afficher $X, \dfrac{M}{N} X + \dfrac{P}{Q}$

 

$\quad \quad$ Sinon

   |

$\quad \quad \quad \quad$ Afficher $-X, - \dfrac{M}{N} X + \dfrac{P}{Q}$

 

$\quad \quad$ Fin si

 

Sinon

   |

$\quad \quad$ Afficher "Pas de solution"

 

Fin Si

 

A) Justifier que cet algorithme se termine pour toute entrée de $M, N, P, Q$ entiers relatifs non nuls tels que $pgcd (M, N) = pgcd (P, Q) = 1$.

B) Que permet-il d'obtenir ?